This module doesn't work in outdated browsers.
If you worried about displaying this module correct, we recommend to install this plugin http://extensions.joomla.org/extension/browser-update-warning which warns your visitors, who have outdated browsers and it offers to update browser. 

The Software Is Provided "AS Is", Without Warranty Of Any Kind, Express Or Implied, Including But Not Limited To The Warranties Of Merchantability, Fitness For A Particular Purpose And Noninfringement.